Some systems are experiencing issues.
i2m has confirmed that clients, including i2m, are currently being affected by this outage/incident.
Investigating - PSA Cloud SlownessDegraded Performance Incident Status: Degraded Performance
Components: PSA
Locations: North America
July 22, 2026 9:20AM EDT July 22, 2026 1:20PM UTC
INVESTIGATING
We are currently investigating reports of performance issues on the NA Cloud with ConnectWise PSA. We will follow up with more information soon.
Incident UUID 06840d7d-0c5e-4991-819c-b53707aa51ad