i2m Client Alert and System Status Page

All systems are operational.

Fixed

1 week ago —

We've concluded our extended period of monitoring and confirmed impact has not reoccurred.

Reported

1 week ago —

Currently, the affected web client, office.com is still impacted. After applying configuration changes and rebalancing the request traffic, the previously impacted Microsoft 365 Copilot web-clients, office.com/chat, m365.cloud.microsoft, m365.cloud.microsoft/chat and copilot.cloud.microsoft, have recovered as of Tuesday, March 17, 2026 at 12:05 PM EDT . We've identified additional configuration changes and are proceeding to roll these out to the affected infrastructure.

Reported

1 week ago —

We've identified that impact associated with MO1253428 has started to reoccur. We're reviewing traffic pattern telemetry and applying configuration changes to optimize connections and remediate impact.

Fixed

1 week ago —

Work to optimize the traffic to the affected section of service infrastructure continues. MS has made additional configuration changes and are monitoring our service side telemetry to verify its effectiveness.

1 week ago —

Issue ID: MO1253428 Affected services: Microsoft 365 Copilot Chat, Microsoft 365 suite, Microsoft Copilot (Microsoft 365) Status: Service degradation Issue type: Incident Start time: Mar 16, 2026, 10:23 AM EDT

User impact Users may be unable to access Office.com or the Microsoft 365 Copilot web sign‑in page.

More info The impacted web-client is office.com, and impacted Microsoft 365 Copilot web-clients are office.com/chat, m365.cloud.microsoft, m365.cloud.microsoft/chat and copilot.cloud.microsoft.

Users can access Microsoft Copilot through application-based Microsoft Copilot services. This includes, but is not limited to:

  • Microsoft Copilot desktop app
  • Copilot in Microsoft Teams
  • Copilot in Office apps

Scope of impact Impact is specific to some users who are served through the affected infrastructure.

Current status Mar 16, 2026, 10:28 AM EDT We've identified that a section of service infrastructure is not processing traffic efficiently. We're making configuration changes to remediate impact. Next update by: Monday, March 16, 2026 at 12:30 PM EDT

i2m has not recieved any reports of the outage affecting i2m clients.

Incident UUID 8f5baa2b-ca9d-4485-b842-7d6c8729caf9